VS:SetTrapeziumAttributes

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTrapeziumAttributes sets the attributes of a trapezium dormer in the referenced roof.

PROCEDURE SetTrapeziumAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDpthDistance :REAL;
bottomWidthDistance :REAL;
useTopWidth :BOOLEAN;
topWidthDistance :REAL;
leftAngle :REAL;
rightAngle :REAL;
topAngle :REAL);
def vs.SetTrapeziumAttributes(roofObject, dormerID, useHeight, heightDpthDistance, bottomWidthDistance, useTopWidth, topWidthDistance, leftAngle, rightAngle, topAngle):
    return None

Parameters

roofObject HANDLE Handle to roof.
dormerID INTEGER Index of dormer element.
useHeight BOOLEAN Use height setting to create dormer element.
heightDpthDistance REAL Height/depth distance.
bottomWidthDistance REAL Bottom width.
useTopWidth BOOLEAN Use top width to create dormer element.
topWidthDistance REAL Top width.
leftAngle REAL Left roof slope.
rightAngle REAL Right roof slope.
topAngle REAL Top roof slope.

Remarks

dormerID: Identifies the which dormer for which to set the values.

useHeight: Set to true if the next value is the height of the dormer, otherwise set to false if the next value is the depth (front to back) of the dormer. heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.

bottomWidth: Dimension of bottom front edge of the dormer, left to right.

useTopWidth: True if using a dimension to set the width of the dormer roof. False if the top width of the dormer is determined by the left and right slope. The topWidth is exclusive of leftSlope & rightSlope. twOrLSlope: dimension of the roof of the dormer if previous param is true, or slope of left dormer wall if false. rightSlope: Angle of right dormer wall.

topSlope: Angle of the roof of the dormer.

Example

VectorScript

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45",2'0",10'0");
AppendRoofEdge(roofHandle, -77'10",21'4.81922",#45",2'0",10'0");
trapID:=CreateTrapeziumDormer(roofHandle);
SetTrapeziumAttributes(roofHandle,trapID,TRUE,6'0",10'0",TRUE,6'0",#0",#0",#8");
SetDormerAttributes(roofHandle,trapID,3,18'4",TRUE,3'0",63,FALSE,3'0");
SetDormerThick(roofHandle, 2",1.83333");

Python


Version

Availability: from VectorWorks8.0