VS:SetTextureRefN

From Vectorworks Developer
Revision as of 14:09, 8 September 2020 by Ptr (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the texture reference for a specified object

PROCEDURE SetTextureRefN(
obj :HANDLE;
textureRef :LONGINT;
texPartID :LONGINT;
texLayerID :LONGINT);
def vs.SetTextureRefN(obj, textureRef, texPartID, texLayerID):
    return None

Parameters

obj HANDLE
textureRef LONGINT
texPartID LONGINT
texLayerID LONGINT 0 for base, >0 for decals

Remarks

(Ptr, 2020 Sep. 8):

vs.SetTextureRefN(obj, textureRef, texPartID, texLayerID)

<lineList ident=1>

textureRef: texture index, -1 for by class texPartID: 3 = overall part texLayerID: 0 for no decals

Version

Availability: from Vectorworks 2010