VS:SetTextVerticalAlign: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextVerticalAlign sets the vertical alignment of the referenced text object.


Justification Constant
Table - Text Vertical Justification
Top of text box 1
Top baseline 2
Text centerline 3
Bottom baseline 4
Bottom of text box 5
PROCEDURE SetTextVerticalAlign(
TextHd :HANDLE;
verticalAlignment :INTEGER);
def vs.SetTextVerticalAlign(TextHd, verticalAlignment):
    return None

Parameters

TextHd HANDLE Handle to text object.
verticalAlignment INTEGER Vertical alignment setting for text.

Remarks

(Orso, 2012 Mai. 27): This routine needs a screen redraw after running. The text object will shift after changing the alignment, use VS:SetTextVertAlignN if the shift is not wished.

Version

Availability: from VectorWorks 8.0

See Also

VS Functions:

VS Functions:
  • [[VS:GetTextVerticalAlign]] | [[VS:SetTextVertAlignN]]
  • [[VS:GetTextJust]] | [[VS:SetTextJust]] | [[VS:SetTextJustN]]