VS:SetTextStyleRefN

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

SetTextStyleRefN sets the text style of a specified substring of a text object to the referenced style. Reference 0 means Un-Styled. This procedure will replace by-class styling.

FUNCTION SetTextStyleRefN(
objectId :HANDLE;
start :INTEGER;
count :INTEGER;
textStyleRef :LONGINT) : BOOLEAN;
def vs.SetTextStyleRefN(objectId, start, count, textStyleRef):
    return BOOLEAN

Parameters

objectId HANDLE handle to text object
start INTEGER Start position in text string, zero-based.
count INTEGER Length of substring.
textStyleRef LONGINT text style reference id

Return Value

Returns False if object is not a text object, or if part of the substring is past the end of existing text. Otherwise returns true.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetTextStyleRef | VS:GetTextStyleRef | VS:GetTextStyleRefN | VS:SetTextStyleByClass | VS:SetTextStyleByClassN | VS:IsTextStyleByClass | VS:IsTextStyleByClassN

VS Functions:

[[VS:SetTextStyleRef]] | [[VS:GetTextStyleRef]] | [[VS:GetTextStyleRefN]] | [[VS:SetTextStyleByClass]] | [[VS:SetTextStyleByClassN]] | [[VS:IsTextStyleByClass]]

| [[VS:IsTextStyleByClassN]]