VS:SetTextSize

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextSize sets the text size of a specified substring in the referenced text object. Parameters Start and Count specify the substring start position and substring length. Parameter Size specifies the size (in points) to be assigned to the substring.

PROCEDURE SetTextSize(
objectHd :HANDLE;
Start :INTEGER;
Count :INTEGER;
Size :REAL);
def vs.SetTextSize(objectHd, Start, Count, Size):
    return None

Parameters

objectHd HANDLE Handle to text object.
Start INTEGER Start position in text string.
Count INTEGER Length of substring.
Size REAL Text size setting for substring.

Remarks

The size parameter was previously an integer, but is now a floating point value. [9/14/98 - PCP]

Example

VectorScript

SetTextSize(HandleToText,0,5,24);
{set the first five characters of the referenced text string to 24 point text}

Python


Version

Availability: from MiniCAD6.0