VS:SetTextJust

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextJust sets the text justification of the referenced text object.


Table - Text Justification
Justification Constant
Left 1
Center 2
Right 3
Justify 4
PROCEDURE SetTextJust(
TextHd :HANDLE;
JustFlag :INTEGER);
def vs.SetTextJust(TextHd, JustFlag):
    return None

Parameters

TextHd HANDLE Handle to text object.
JustFlag INTEGER Justification setting for text.

Remarks

(Orso, 2012 Mai. 26): The constant 4 "Justify" is introduced by VW 2011. This routine needs a screen redraw after running. The text object will shift after changing the alignment, use VS:SetTextJustN if the shift is not wished.

Version

Availability: from MiniCAD 6.0

See Also

VS Functions:

VS Functions:
  • [[VS:GetTextJust]] | [[VS:SetTextJustN]]
  • [[VS:GetTextVerticalAlign]] | [[VS:SetTextVerticalAlign]]