VS:SetTextFont

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTextFont sets the font of a substring in the referenced text object.

PROCEDURE SetTextFont(
objectHd :HANDLE;
Start :INTEGER;
Count :INTEGER;
FontNum :INTEGER);
def vs.SetTextFont(objectHd, Start, Count, FontNum):
    return None

Parameters

objectHd HANDLE Handle to text object.
Start INTEGER Start position in text string.
Count INTEGER Length of substring.
FontNum INTEGER Font ID for substring.

Remarks

Note that "Start" is zero-based.

Example

VectorScript

SetTextFont(handleToText,0,5,GetFontID('Helvetica'));

{sets the first five characters of the referenced text string to Helvetica}

Python


Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:GetFontID

VS Functions: [[VS:GetFontID]]