VS:SetTextEditable

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the editable state of a text field in an existing dialog. This function should be called from the event handler for the dialog, not during the dialog setup.

PROCEDURE SetTextEditable(
item :INTEGER;
editable :BOOLEAN);
def vs.SetTextEditable(item, editable):
    return None

Parameters

item INTEGER the id of the item
editable BOOLEAN editable state

Remarks

Note: deprecated from VW 15+, use EnableTextEdit.

When applied directly to a text box, simply sets the editable state. When applied to a scroller text or other "complex" text object, sets the editable state of just the text field. This function will not work if the dialog does not already exist, and therefore cannot be used during dialog setup. 8/12/04

Version

Availability: from VectorWorks 11.5. Deprecated from VW 15+.