VS:SetTextAdorner

From Vectorworks Developer
Revision as of 17:41, 16 September 2010 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates a relationship between the specified text block and the text adorner such that when theText Block is scaled in a VP, the text adorner is also scaled. Several objects can be adorned to the same text object.

FUNCTION SetTextAdorner(
textBlock :HANDLE;
textAdorner :HANDLE;
p :REAL) : Boolean;
def vs.SetTextAdorner(textBlock, textAdorner, p):
    return Boolean

Parameters

textBlock HANDLE The Text object being adorned.
textAdorner HANDLE The object used to adorn the specified text.
p REAL The point by which texts will be scaled.

Return Value

- 'true' if the operation was successful.

- 'false' otherwise.

Example

PROCEDURE Example;
VAR
theText      :HANDLE;
theShape : HANDLE;
restult :      BOOLEAN;
BEGIN
TextVerticalAlign(3);
TextJust(2);
MoveTo(0,0);
RectangleN(-.5",      -.5", 1, 0, 1", 1");
theShape :=      lNewObj;
CreateText('ID1');
theText :=      lNewObj;
restult :=      SetTextAdorner(theText,theShape,0,0);
END;
RUN(Example);

Version

Availability: from Vectorworks 2011