VS:SetTexSpaceOrigin: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpaceOrigin sets the offset of the referenced texture space that takes coordinates from world space to texture space.

PROCEDURE SetTexSpaceOrigin(
textureSpace :HANDLE;
offsetX,offsetY,offsetZ :REAL);
def vs.SetTexSpaceOrigin(textureSpace, offset):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
offset REAL Texture space offset value.

Remarks

Sets the offset that takes coordinates from world space to texture space

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks8.0