VS:SetTexSpaceOrientW

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpaceOrientW specifies the vector that describes the w-axis of the referenced texture (from world space to texture space).

PROCEDURE SetTexSpaceOrientW(
textureSpace :HANDLE;
wXAxis :REAL;
wYAxis :REAL;
wZAxis :REAL);
def vs.SetTexSpaceOrientW(textureSpace, wXAxis, wYAxis, wZAxis):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
wXAxis REAL Sets w-axis vector X component.
wYAxis REAL Sets w-axis vector Y component.
wZAxis REAL Sets w-axis vector Z component.

Remarks

Sets the w-axis for the texture space (from world space to texture space)

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks8.0