VS:SetTexSpaceKind

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpaceKind sets the object type for referenced texture mapping space.

Table - Texture Mapping Spaces
Date Style Constant
Plane 0
Sphere 1
Cylinder 2
Algorithmic 3
PROCEDURE SetTexSpaceKind(
textureSpace :HANDLE;
kind :INTEGER);
def vs.SetTexSpaceKind(textureSpace, kind):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
kind INTEGER Texture mapping space type.

Remarks

Sets the kind for the texture mapping space; 0 = Plane space, 1 = Sphere, 2 = Cylinder, and 3 = Algorithmic (Perimeter or Roof)

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0