VS:SetTexSpace2DScale

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpace2DScale sets the 2D scale for the referenced texture space. Parameter scale specifies the new scale value.

PROCEDURE SetTexSpace2DScale(
textureSpace :HANDLE;
scale :REAL);
def vs.SetTexSpace2DScale(textureSpace, scale):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
scale REAL Scale for texture space.

Remarks

Sets the 2D scale for this texture space as a multiple of a default size of 1.

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks8.0