VS:SetTexSpace2DRot: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(expand info)
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018.
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use [[VS:GetTexMapRealN]] instead.
 


Sets rotation in degrees
Sets rotation in degrees

Revision as of 08:07, 29 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetTexSpace2DRot sets the rotation of the referenced texture space.

PROCEDURE SetTexSpace2DRot(
textureSpace :HANDLE;
rotationDegrees :REAL);
def vs.SetTexSpace2DRot(textureSpace, rotationDegrees):
    return None

Parameters

textureSpace HANDLE Handle to texture space.
rotationDegrees REAL Rotation of texture space(in degrees).

Remarks

(Orso, 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use VS:GetTexMapRealN instead.


Sets rotation in degrees

Note: SetTexMapXXX routines replace the older SetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0