VS:SetTexMapRealN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set map info for specific part of object. partID is texture part, overall is 3. Selector: offsetX:1, offsetY:2, scale2D:3, rotate2D:4, radius:5, matrix mat00 through mat32: 6-17

PROCEDURE SetTexMapRealN(
obj :HANDLE;
texPartID :LONGINT;
texLayerID :LONGINT;
selector :INTEGER;
value :REAL);
def vs.SetTexMapRealN(obj, texPartID, texLayerID, selector, value):
    return None

Parameters

obj HANDLE
texPartID LONGINT
texLayerID LONGINT 0 for base, >0 for decals
selector INTEGER
value REAL

Version

Availability: from Vectorworks 2010