VS:SetTexMapReal

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set map info for specific part of object. partID is texture part, overall is 3.

Selector:

  • offsetX:1
  • offsetY:2
  • scale2D:3
  • rotate2D:4
  • radius:5
  • matrix mat00 through mat32: 6-17
These values are the coefficients for the 4 row x 3 column object space to texture space 3D transform matrix. These values are changed by things like the Edit Mapping dialog.
PROCEDURE SetTexMapReal(
h :HANDLE;
partID :LONGINT;
selector :INTEGER;
value :REAL);
def vs.SetTexMapReal(h, partID, selector, value):
    return None

Parameters

h HANDLE
partID LONGINT
selector INTEGER
value REAL

Version

Availability: from Vectorworks14.0

See Also

VS:GetTexMapReal

[[VS:GetTexMapReal]]