VS:SetTexMapInt

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set map info for specific part of object. partID is texture part, overall is 3. Selector should be 1 to set the map type integer.

PROCEDURE SetTexMapInt(
h :HANDLE;
partID :LONGINT;
selector :INTEGER;
value :INTEGER);
def vs.SetTexMapInt(h, partID, selector, value):
    return None

Parameters

h HANDLE
partID LONGINT
selector INTEGER
value INTEGER

Remarks

Value is one of the:

kPlaneSpace = 0;
kSphereSpace = 1;
kCylinderSpace = 2;
kAlgorithmicSpace = 3; {Space that wraps around the object most}

Algorithmic means either the "perimeter" or "roof" mapping type.

Version

Availability: from Vectorworks14.0

See Also

VS:GetTexMapInt

[[VS:GetTexMapInt]]