VS:SetTexMapBool

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set map info for specific part of object. partID is texture part, overall is 3.

Selector:

  • init:1
  • flip:2
  • repH:3
  • repV:4
  • long edge:5
  • worldZ:6
  • auto align:7
PROCEDURE SetTexMapBool(
h :HANDLE;
partID :LONGINT;
selector :INTEGER;
value :BOOLEAN);
def vs.SetTexMapBool(h, partID, selector, value):
    return None

Parameters

h HANDLE
partID LONGINT
selector INTEGER
value BOOLEAN

Remarks

The init value is whether the texture mapping info contains valid information. If the mapping is not really set to important values then the init value will be false. This can happen if the mapping was not set with VS:SetDefaultTexMap.

Version

Availability: from Vectorworks14.0

See Also

VS:GetTexMapBool | VS:SetDefaultTexMap

[[VS:GetTexMapBool]] | [[VS:SetDefaultTexMap]]