VS:SetSymbolOptionsN

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the default class, insert options, and break options for the specified symbol.

Table - Symbol Insertion Options
Insertion Mode Description Constant Value
Insert on Center Line 0
Insert on Edge 1
Break Mode Description Constant Value
Full Break with Caps 1
Full Break No Caps 2
Half Break 3
No Break 4
PROCEDURE SetSymbolOptionsN(
name :STRING;
insertMode :INTEGER;
breakMode :INTEGER;
className :STRING);
def vs.SetSymbolOptionsN(name, insertMode, breakMode, className):
    return None

Parameters

name STRING Name of symbol.
insertMode INTEGER Insertion mode of symbol.
breakMode INTEGER Break mode for symbol.
className STRING Default class for symbol.

Remarks

Sets the insert and break options for the master symbol named <name>.

The insertMode options are: 0 = insert on the center line of the wall 1 = insert on the edge of the wall

The breakMode options are: 1 = Full break with caps, both edges of the wall are broken and cap lines close off the two broken portions of the wall. 2 = Full break with no caps, both edges of the wall are broken and there are no cap lines. 3 = Half break, for edge insertions only, wall edge is broken on the same edge that the symbol is inserted on. 4 = No break, there is no break in the wall, the symbol is drawn on top of the wall.

See also Get SymbolOptions

[sd 8/18/98]

The className should specify the name of a class that exists in the parent document. After a class is set, all instances of this symbol will be marked as members of the class.

Version

Availability: from VectorWorks 8.5