VS:SetSkylight

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function SetSkylight sets the definition attributes of a skylight in the referenced roof object.

PROCEDURE SetSkylight(
roofObject :HANDLE;
skylightID :INTEGER;
edgeIndex :INTEGER;
cornerOffsetDistance :REAL;
perpOffsetDistance :REAL;
symName :LONGINT);
def vs.SetSkylight(roofObject, skylightID, edgeIndex, cornerOffsetDistance, perpOffsetDistance, symName):
    return None

Parameters

roofObject HANDLE Handle to roof.
skylightID INTEGER Index of skylight element.
edgeIndex INTEGER Index of roof edge associated with skylight.
cornerOffsetDistance REAL Offset of skylight from corner.
perpOffsetDistance REAL Offset of skylight from roof edge.
symName LONGINT Name of skylight symbol.

Remarks

skylightID: Identifier for this skylight. Value is returned by CreateSkylight().

edgeIndex: Index to which roof face this skylight is placed. Value is one based. cornerOffset: Top/Plan distance from vertex referenced by 'edgeIndex' to center of skylight. This distance is parallel to the roof outline as defined by: vertex[edgeindex+1] - vertex[edgeIndex]. perpOffset: Top/Plan distance from roof outline to center of skylight. symName: Skylight symbol to place in the roof.

Example

VectorScript

skylightID:=CreateSkylight(roofHandle);
SetSkylight(roofHandle,skylightID,6,13'8",2'1",Name2Index('dh2436'));

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:Name2Index

VS Functions: [[VS:Name2Index]]