VS:SetShedAttributes/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根の中の、片流れのドーマーを設定します。

PROCEDURE SetShedAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDepthDistance :REAL)Coordinate); bottomWidthDistance:REAL (Coordinate); overhangDistance:REAL (Coordinate); topAngle:REAL);
def vs.SetShedAttributes(roofObject, dormerID, useHeight, heightDepthDistance, bottomWidthDistance, overhangDistance, topAngle):
    return None

Parameters

roofObject HANDLE 屋根のハンドル
dormerID INTEGER ドーマーの番号
useHeight BOOLEAN 高さ設定の有無
heightDepthDistance REAL (Coordinate) 高さまたは厚み
bottomWidthDistance REAL (Coordinate) 下部の幅
overhangDistance REAL (Coordinate) 張り出し距離
topAngle REAL 上側の傾斜角度

Example

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45°0'0" ,2'0",10'0");
shedID := CreateShedDormer(roofHandle);
SetShedAttributes(roofHandle,shedID,TRUE,6'0",10'0",2'0",#8°0'0");
SetDormerAttributes(roofHandle,shedID,3,18'4",TRUE,3'0",63,FALSE, 3'0");
SetDormerThick(roofHandle, 2",1.83333");

Version

利用可能バージョン: VectorWorks8.0