VS:SetShedAttributes

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetShedAttributes sets the attributes of a shed dormer in the referenced roof.

PROCEDURE SetShedAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDepthDistance :REAL;
bottomWidthDistance :REAL;
overhangDistance :REAL;
topAngle :REAL);
def vs.SetShedAttributes(roofObject, dormerID, useHeight, heightDepthDistance, bottomWidthDistance, overhangDistance, topAngle):
    return None

Parameters

roofObject HANDLE Handle to roof.
dormerID INTEGER Index of dormer element.
useHeight BOOLEAN Use height setting to create dormer element.
heightDepthDistance REAL Height/depth distance.
bottomWidthDistance REAL Bottom width.
overhangDistance REAL Overhang distance.
topAngle REAL Top angle of dormer element.

Remarks

dormerID: Identifies the dormer for which to set the information.

useHeight: true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer heightDepthValue: size of the dormer, either by height or depth; determined by previous parameter.

bottomWidth: Dimension of bottom front edge of the dormer, left to right.

topSlope: Angle of dormer roof.

overhang: Distance roof projects past dormer walls.

Example

VectorScript

PROCEDURE Test; 
VAR
    roofHandle : HANDLE; 
	shedID : INTEGER;
BEGIN
    roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
	AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45,2'0",10'0");
	AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45,2'0",10'0");
	AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45,2'0",10'0");
	AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45 ,2'0",10'0");
	shedID:=CreateShedDormer(roofHandle);
	SetShedAttributes(roofHandle,shedID,TRUE,6'0",10'0",2'0",#8);
	SetDormerAttributes(roofHandle,shedID,3,18'4",TRUE,3'0",63,FALSE, 3'0");
	SetDormerThick(roofHandle, 2",1.83333");
END; 
RUN(Test);

Python

def Test():
	roofHandle = vs.CreateRoof(True,5*12+1/2,5*12+1/2,4,9.52627)
	vs.AppendRoofEdge(roofHandle,-77*12+10,-25*12+3.18078,45,2*12,10*12)
	vs.AppendRoofEdge(roofHandle,-41*12+2,-25*12+3.18078,45,2*12,10*12)
	vs.AppendRoofEdge(roofHandle,-41*12+2,21*12+4.81922,45,2*12,10*12)
	vs.AppendRoofEdge(roofHandle,-77*12+10,21*12+4.81922,45 ,2*12,10*12)
	shedID=vs.CreateShedDormer(roofHandle)
	vs.SetShedAttributes(roofHandle,shedID,True,6*12,10*12,2*12,8)
	vs.SetDormerAttributes(roofHandle,shedID,3,18*12+4,True,3*12,63,False, 3*12);
	vs.SetDormerThick(roofHandle, 2,1.83333)
Test()

Version

Availability: from VectorWorks8.0