VS:SetScriptResource

From Vectorworks Developer
Revision as of 17:34, 18 September 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the script text of the specified script resource.

FUNCTION SetScriptResource(
scriptName :STRING;
script :DYNARRAY[] of CHAR;
python :BOOLEAN) : BOOLEAN;
def vs.SetScriptResource(scriptName, script, python):
    return BOOLEAN

Parameters

scriptName STRING The script name identifying the resource.
script DYNARRAY[] of CHAR The script text.
python BOOLEAN Pass TRUE if the script text contains python script. Otherwise it will be considered VectorScript.

Return Value

Return TRUE if the creation was successful. The routine will fail if script with the specified name does't exist.

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateScriptResource | VS:GetScriptResource | VS:OpenScriptResPal

VS Functions:

[[VS:CreateScriptResource]] | [[VS:GetScriptResource]]

| [[VS:OpenScriptResPal]]