VS:SetSavedSetting: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Writes a value to the saved settings file. This can be used to remember various user settings between running sessions of VectorWorks. For example, a script may want to remember a dialog's position or a font settings. The saved settings should not be used for critical information, but rather for convenience settings.

PROCEDURE SetSavedSetting(
category :STRING;
setting :STRING;
value :STRING);
def vs.SetSavedSetting(category, setting, value):
    return None

Parameters

category STRING
setting STRING
value STRING

Remarks

This stores the data on SavedSettingsUser.xml.

If the file SavedSettingsUser.xml is missing, it will be created in the users>Settings folder AFTER quitting VectorWorks and only if the file calling this routine is saved (VW 12.x).

This seems to mean that the whole xml is stored on memory as long as the VW session is open. It will be written and released after quitting the application. Not clear as to what happens if you keep on calling this routine from a large number of scripts, on a large number of open files, using a large number of different setting values.

Version

Availability: from VectorWorks12.0

See Also

VS:GetSavedSetting

[[VS:GetSavedSetting]]