VS:SetRot3D

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetRot3D sets the rotation (in degrees) of the referenced object to the specified rotations and center. This procedure works on the following 3D objects: extrudes, multiple extrudes, and sweeps.

The difference between Set3DRot and SetRot3D is that Set3DRot adds the specified rotation to the existing rotation of the object, whereas SetRot3D does not consider the existing rotation, and merely makes the object rotation match the specified values.

PROCEDURE SetRot3D(
h :HANDLE;
xAngle :REAL;
yAngle :REAL;
zAngle :REAL;
xDistance :REAL;
yDistance :REAL;
zDistance :REAL);
def vs.SetRot3D(h, xAngle, yAngle, zAngle, xDistance, yDistance, zDistance):
    return None

Parameters

h HANDLE Handle to 3D object.
xAngle REAL New X rotation angle.
yAngle REAL New Y rotation angle.
zAngle REAL New Z rotation angle.
xDistance REAL X coordinate of rotation center.
yDistance REAL Y coordinate of rotation center.
zDistance REAL Z coordinate of rotation center.

Remarks

[sd 8/18/98]

Version

Availability: from All Versions

See Also

VS Functions:

VS:Set3DRot

VS Functions: [[VS:Set3DRot]]