VS:SetRoofAttributes/ja

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根を設定します。

PROCEDURE SetRoofAttributes(
roofObject :HANDLE;
genGableWall :BOOLEAN;
bearingInsetDistance :REAL)Coordinate); roofThickDistance:REAL (Coordinate); miterType:INTEGER; vertMiterDistance:REAL (Coordinate));
def vs.SetRoofAttributes(roofObject, genGableWall, bearingInsetDistance, roofThickDistance, miterType, vertMiterDistance):
    return None

Parameters

roofObject HANDLE 屋根のハンドル
genGableWall BOOLEAN 切り妻の有無
bearingInsetDistance REAL (Coordinate) 壁からの距離
roofThickDistance REAL (Coordinate) 屋根の厚み
miterType INTEGER 切り妻の種類
vertMiterDistance REAL (Coordinate) 切り妻の高さ

Example

PROCEDURE Example;
VAR
	thickness :REAL;
	str	:STRING;

PROCEDURE SetIt(h :HANDLE);
BEGIN
	IF GetObjectVariableInt(h, 172) = 1 THEN 
		SetObjectVariableReal(h, 170, thickness * 25.4);
END;

PROCEDURE FindRoofFaces(h :HANDLE);
VAR
	temp_h :HANDLE;
	roofObject :HANDLE; 
	genGableWall :BOOLEAN; 
	bearingInsetDistance, roofThickDistance :REAL; 
	miterType :INTEGER; 
	vertMiterDistance :REAL;
BEGIN
	IF GetType(h) = 71 THEN SetIt(h) ELSE
	IF GetRoofAttributes(h, genGableWall, bearingInsetDistance, roofThickDistance, miterType, vertMiterDistance) THEN
		SetRoofAttributes(h, genGableWall, bearingInsetDistance, thickness, miterType, vertMiterDistance);
END;

BEGIN
	thickness := RealDialog('Enter desired thickness', '10');
	str := Concat('((T=71) | (T=83)) & (L=''', GetLName(ActLayer), ''')');
	ForEachObject(FindRoofFaces, str);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks8.0