VS:SetResourceTags

From Vectorworks Developer
Revision as of 09:07, 26 February 2017 by CBM-c- (talk | contribs) (add remark about array size also here)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds the specified tags to the specified resource.

PROCEDURE SetResourceTags(
handle :HANDLE;
tags :ARRAY);
def vs.SetResourceTags(handle, tags):
    return None

Parameters

handle HANDLE The handle to the resource.
tags ARRAY The list of tags.

Remarks

(Orso, 2017.02.26): The array to be used is an ARRAY[] OF STRING. The Array can be probably sized up to integer limit 32767. Note: large arrays cause a really heavy delay upon any action on the involved resource, such as attempts to select it in the Resource Manager. The tags array should be kept small.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:GetResourceTags | VS:GetNumResourceTags

VS Functions:

[[VS:GetResourceTags]]

| [[VS:GetNumResourceTags]]