VS:SetResourceTags: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(add remark about array size also here)
(One intermediate revision by one other user not shown)
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2017.02.26): The array to be used is an ARRAY[] OF STRING. The Array can be probably sized up to integer limit 32767. Note: large arrays cause a really heavy delay upon any action on the involved resource, such as attempts to select it in the Resource Manager. The tags array should be kept small.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:07, 26 February 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds the specified tags to the specified resource.

PROCEDURE SetResourceTags(
handle :HANDLE;
tags :ARRAY);
def vs.SetResourceTags(handle, tags):
    return None

Parameters

handle HANDLE The handle to the resource.
tags ARRAY The list of tags.

Remarks

(Orso, 2017.02.26): The array to be used is an ARRAY[] OF STRING. The Array can be probably sized up to integer limit 32767. Note: large arrays cause a really heavy delay upon any action on the involved resource, such as attempts to select it in the Resource Manager. The tags array should be kept small.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:GetResourceTags | VS:GetNumResourceTags

VS Functions:

[[VS:GetResourceTags]]

| [[VS:GetNumResourceTags]]