VS:SetRFieldOpt

From Vectorworks Developer
Revision as of 15:47, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set options for a record field.

PROCEDURE SetRFieldOpt(
h :HANDLE;
record :STRING;
field :STRING;
isEmpty :BOOLEAN;
isDataLinked :BOOLEAN);
def vs.SetRFieldOpt(h, record, field, isEmpty, isDataLinked):
    return None

Parameters

h HANDLE Handle to a object with an attached record.
record STRING Name of record to be updated.
field STRING Name of field to be updated.
isEmpty BOOLEAN Option to set, specifying this field as empty data for the Data Manager.
isDataLinked BOOLEAN Option to set, specifying this field data linked for the Data Manager.

Example

SetRField(HandleToObject,'Part Info','Serial No.',False, False);

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:GetRFieldOpt | VS:GetRField | VS:SetRField

VS Functions:

[[VS:GetRFieldOpt]] | [[VS:GetRField]]

| [[VS:SetRField]]