VS:SetProportionalBinding

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets a dialog control?s bindings to be proportional. Proportional bindings maintain a distance that is a ratio of the initial position to the width (or height, as appropriate) of the parent. To change a control?s bindings to be fixed, use SetEdgeBinding.

PROCEDURE SetProportionalBinding(
dialogID :LONGINT;
itemID :LONGINT;
leftProportional :BOOLEAN;
rightProportional :BOOLEAN;
topProportional :BOOLEAN;
bottomProportional :BOOLEAN);
def vs.SetProportionalBinding(dialogID, itemID, leftProportional, rightProportional, topProportional, bottomProportional):
    return None

Parameters

dialogID LONGINT
itemID LONGINT
leftProportional BOOLEAN
rightProportional BOOLEAN
topProportional BOOLEAN
bottomProportional BOOLEAN

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:CreateResizableLayout | VS:SetEdgeBinding

VS Functions:

[[VS:CreateResizableLayout]]

| [[VS:SetEdgeBinding]]