VS:SetPrefLongInt

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of the specified VectorWorks preference setting. Used with preference settings requiring a LONGINT value.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

PROCEDURE SetPrefLongInt(
index :INTEGER;
value :LONGINT);
def vs.SetPrefLongInt(index, value):
    return None

Parameters

index INTEGER Preference item index.
value LONGINT New value for preference.

Remarks

Sets the value of the specified preference to the value passed. Similar to SetPref() except it works on preferences for long integer values

Example

VectorScript

SetPrefLongInt(55,128);

Python


Version

Availability: from VectorWorks9.0