VS:SetPlanarRef

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the plane ref ID of the specified object.

PROCEDURE SetPlanarRef(
h :HANDLE;
refID :LONGINT);
def vs.SetPlanarRef(h, refID):
    return None

Parameters

h HANDLE Handle to the object.
refID LONGINT Reference ID of the plane.

Remarks

The refID is the return value from GetPlanarRef(). As noted in GetCurrentPlanarRefID().

Screen Plane has a ref ID of 0. Layer Plane has a ref ID of -1.

Rgm [2012.05.16]: Seems to be equivalent to SetObjectVariableBoolean(hd, 1160, TRUE);

In VW2011, this will silently fail to set an object to Screen Plane unless the object's Z is the negative of the Layer Z of the design layer the object exists on.

For example, if GetZVals(zVal, deltaZVal) gives a non-zero zVal, you'll have to call Move3DObj(hd, 0, 0, -zVal) before SetPlanarRef(hd,0) will have any effect.

Version

Availability: from Vectorworks 2011