VS:SetOpacityByClass

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified class to use the class opacity.

PROCEDURE SetOpacityByClass(
h :HANDLE);
def vs.SetOpacityByClass(h):
    return None

Parameters

h HANDLE The object which opacity will be set.

Remarks

If you set opacity to an object inside parametric the actual opacity will be combined with the opacity of the parametric object itself. For example a rectangle with 50% opacity inside a parametric with 50% opacity will actually be rendered with 25% opacity. This behavior is the same for symbols too.

Version

Availability: from VectorWorks13.0

See Also

VS:GetOpacity | VS:SetOpacity | VS:GetOpacityByClass | VS:SetOpacityByClass

[[VS:GetOpacity]] | [[VS:SetOpacity]] | [[VS:GetOpacityByClass]] | [[VS:SetOpacityByClass]]