VS:SetOpacity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the opacity of the object to the opacity passed in.

PROCEDURE SetOpacity(
h :HANDLE;
opacity :INTEGER);
def vs.SetOpacity(h, opacity):
    return None

Parameters

h HANDLE Object to which the opacity should be applied.
opacity INTEGER The opacity value from 0 to 100, where 0 means fully transparent; 100 - fully solid.

Remarks

If you set opacity to an object inside parametric the actual opacity will be combined with the opacity of the parametric object itself. For example a rectangle with 50% opacity inside a parametric with 50% opacity will actually be rendered with 25% opacity. This behavior is the same for symbols too.

Version

Availability: from VectorWorks13.0

See Also

VS:GetOpacity | VS:SetOpacity | VS:GetOpacityByClass | VS:SetOpacityByClass

[[VS:GetOpacity]] | [[VS:SetOpacity]] | [[VS:GetOpacityByClass]] | [[VS:SetOpacityByClass]]