VS:SetObjectWallOffset

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets an object's offset value in it's break record.


The object (objH) must be contained in wall (wallH) for the setting to succeed.

FUNCTION SetObjectWallOffset(
objH :HANDLE;
wallH :HANDLE;
offset :REAL) : BOOLEAN;
def vs.SetObjectWallOffset(objH, wallH, offset):
    return BOOLEAN

Parameters

objH HANDLE Handle of object to set a new offset value for.
wallH HANDLE Handle of wall containing the object references in objH.
offset REAL Value of new offset for object within wall.

Return Value

True or False upon successfull setting of the flag.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Remarks

Julian: [2009/08/30] The offset value is to the centre of the object.

Version

Availability: from Vectorworks 2010