VS:SetObjectWallHeight

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets an object's height value in it's break record.

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjectWallHeight(
objH :HANDLE;
wallH :HANDLE;
height :REAL)Coordinate)) : BOOLEAN;
def vs.SetObjectWallHeight(objH, wallH, height):
    return BOOLEAN

Parameters

objH HANDLE
wallH HANDLE
height REAL (Coordinate)

Return Value

True or False upon successful setting of the flag.

False can occur for the following conditions:

objH is null
wallH is null
objH is not contained in wallH.

Version

Availability: from Vectorworks 2015