VS:SetObjectWallHeight: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(successful, not successfull. I looked this one up)
 
(2 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets an object's height value in it's break record. <BR>
Sets an object's height value in it's break record.
<BR>
 
The oject (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 44: Line 44:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successfull setting of the flag.<BR>
True or False upon successful setting of the flag.
<BR>
 
False can occur for the following conditions:<BR>
False can occur for the following conditions:
objH is null.<BR>
: objH is null
wallH is null.<BR>
: wallH is null
objH is not contained in wallH.</return>
: objH is not contained in wallH.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 15:10, 21 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets an object's height value in it's break record.

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjectWallHeight(
objH :HANDLE;
wallH :HANDLE;
height :REAL)Coordinate)) : BOOLEAN;
def vs.SetObjectWallHeight(objH, wallH, height):
    return BOOLEAN

Parameters

objH HANDLE
wallH HANDLE
height REAL (Coordinate)

Return Value

True or False upon successful setting of the flag.

False can occur for the following conditions:

objH is null
wallH is null
objH is not contained in wallH.

Version

Availability: from Vectorworks 2015