VS:SetObjectVariableBoolean: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
(add missing handle to the example)
 
(One intermediate revision by one other user not shown)
Line 48: Line 48:
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
SetObjectVariableBoolean(17,FALSE);
SetObjectVariableBoolean(obj, 17, FALSE);
</code>
</code>
==== Python ====
==== Python ====
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks9.0
Availability: from VectorWorks 9.0


</version>
</version>

Latest revision as of 03:46, 2 June 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the ON-OFF status of a VectorWorks object property.

For specific object selector index values, see the Appendix.

PROCEDURE SetObjectVariableBoolean(
h :HANDLE;
index :INTEGER;
status :BOOLEAN);
def vs.SetObjectVariableBoolean(h, index, status):
    return None

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.
status BOOLEAN New status for property.

Example

VectorScript

SetObjectVariableBoolean(obj, 17, FALSE);

Python


Version

Availability: from VectorWorks 9.0