VS:SetObjectStoryBound/ja

From Vectorworks Developer
Revision as of 06:51, 11 January 2017 by Kimura (talk | contribs) (1 revision: 2017 JP S)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した図形の高さ基準に関するデータを設定します。

PROCEDURE SetObjectStoryBound(
object :HANDLE;
boundID :INTEGER;
boundType :INTEGER;
boundStory :INTEGER;
layerLevelType :STRING;
offset :REAL);
def vs.SetObjectStoryBound(object, boundID, boundType, boundStory, layerLevelType, offset):
    return None

Parameters

object HANDLE 図形のハンドル
boundID INTEGER 高さ基準の識別子
boundType INTEGER 高さ基準のタイプ : 0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
boundStory INTEGER 高さ基準のタイプ boundType = 2 の場合、0 : 図形の高さ基準; 1 : 上のストーリ; -1 : 下のストーリ
layerLevelType STRING レベルタイプ
offset REAL オフセット

Version

利用可能バージョン: Vectorworks 2012

See Also

関連関数:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

関連関数:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]