VS:SetObjectStoryBound: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Shorten OBJECT, reserved word)
No edit summary
 
Line 40: Line 40:
boundStory
boundStory
INTEGER
INTEGER
The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = 2 then it is the story below.
The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = -1 then it is the story below.
</line>
</line>
<line>
<line>

Latest revision as of 10:21, 17 July 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the data of the specified story bound of this object.

PROCEDURE SetObjectStoryBound(
obj :HANDLE;
boundID :INTEGER;
boundType :INTEGER;
boundStory :INTEGER;
layerLevelType :STRING;
offset :REAL);
def vs.SetObjectStoryBound(obj, boundID, boundType, boundStory, layerLevelType, offset):
    return None

Parameters

obj HANDLE The object.
boundID INTEGER The identifier of the story bound.
boundType INTEGER Bounding type: 0 - LayerZ; 1 - DefaultWallHeight; 2 - Story
boundStory INTEGER The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = -1 then it is the story below.
layerLevelType STRING The layer type which defines this bound
offset REAL The offset distance from the specified bound story

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

VS Functions:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]