VS:SetObjWallInsertMode

From Vectorworks Developer
Revision as of 06:49, 14 January 2017 by CBM-c- (talk | contribs) (wikify to remove extra spaces)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the insertion mode for an object in a wall.

1 - Center
2 - Leaf Edge
3 - Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
insertMode :INTEGER) : Boolean;
def vs.SetObjWallInsertMode(objH, wallH, insertMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful setting of the insertion mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null

objH is not contained in wallH.

Version

Availability: from Vectorworks 2017