VS:SetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(wikify to remove extra spaces)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Set the insertion mode for an object in a wall.<BR>
Set the insertion mode for an object in a wall.
<BR>
 
1 - Center<BR>
1 - Center<BR>
2 - Leaf Edge<BR>
2 - Leaf Edge<BR>
3 - Right Edge<BR>
3 - Right Edge<BR>
<BR>
 
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


Line 49: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful setting of the insertion mode.<BR>
True or False upon successful setting of the insertion mode.
<BR>
 
False can occur for the following conditions:<BR>
False can occur for the following conditions:
objH is null.<BR>
* objH is null
wallH is null.<BR>
* wallH is null
objH is not contained in wallH.</return>
objH is not contained in wallH.</return>



Revision as of 06:49, 14 January 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the insertion mode for an object in a wall.

1 - Center
2 - Leaf Edge
3 - Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
insertMode :INTEGER) : Boolean;
def vs.SetObjWallInsertMode(objH, wallH, insertMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful setting of the insertion mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null

objH is not contained in wallH.

Version

Availability: from Vectorworks 2017