VS:SetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (1 revision)
 
(No difference)

Latest revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the insertion mode for an object in a wall.


1 - Center
2 - Leaf Edge
3 - Right Edge


The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
insertMode :INTEGER) : Boolean;
def vs.SetObjWallInsertMode(objH, wallH, insertMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful setting of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017