VS:SetObjWallBreakMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(wikify to remove extra spaces)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Set the break mode for an object in a wall.<BR>
Set the break mode for an object in a wall.
<BR>
# Full Break with Caps
1 - Full Break with Caps<BR>
# Full Break no Caps
2 - Full Break no Caps<BR>
# Half Break
3 - Half Break<BR>
# No Break
4 - No Break<BR>
 
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


Line 49: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful setting of the break mode.<BR>
True or False upon successful setting of the break mode.
<BR>
 
False can occur for the following conditions:<BR>
False can occur for the following conditions:
objH is null.<BR>
* objH is null
wallH is null.<BR>
* wallH is null
objH is not contained in wallH.</return>
objH is not contained in wallH.</return>



Revision as of 06:47, 14 January 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the break mode for an object in a wall.

  1. Full Break with Caps
  2. Full Break no Caps
  3. Half Break
  4. No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
breakMode :INTEGER) : Boolean;
def vs.SetObjWallBreakMode(objH, wallH, breakMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful setting of the break mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null

objH is not contained in wallH.

Version

Availability: from Vectorworks 2017