VS:SetObjWallBreakMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(wikify to remove extra spaces)
(no, better leave hard-coded numbers)
Line 7: Line 7:
<desc>
<desc>
Set the break mode for an object in a wall.
Set the break mode for an object in a wall.
# Full Break with Caps
1 - Full Break with Caps<BR>
# Full Break no Caps
2 - Full Break no Caps<BR>
# Half Break
3 - Half Break<BR>
# No Break
4 - No Break<BR>


The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>

Revision as of 06:48, 14 January 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the break mode for an object in a wall.

1 - Full Break with Caps
2 - Full Break no Caps
3 - Half Break
4 - No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
breakMode :INTEGER) : Boolean;
def vs.SetObjWallBreakMode(objH, wallH, breakMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful setting of the break mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null

objH is not contained in wallH.

Version

Availability: from Vectorworks 2017