VS:SetObjWallBreakMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (wikify)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Set the break mode for an object in a wall.
Set the break mode for an object in a wall.<BR>
<BR>
1 - Full Break with Caps<BR>
1 - Full Break with Caps<BR>
2 - Full Break no Caps<BR>
2 - Full Break no Caps<BR>
3 - Half Break<BR>
3 - Half Break<BR>
4 - No Break<BR>
4 - No Break<BR>
 
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


Line 48: Line 49:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful setting of the break mode.
True or False upon successful setting of the break mode.<BR>
 
<BR>
False can occur for the following conditions:
False can occur for the following conditions:<BR>
* objH is null
objH is null.<BR>
* wallH is null
wallH is null.<BR>
* objH is not contained in wallH.
objH is not contained in wallH.</return>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark></remark>
([[User:Orso.b.schmid|Orso]], 2020.04.14)
Fails on Round Walls, while on straight walls you must regen the wall and coerce a redraw (bug filed, tested on VW 2019, 2020).
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the break mode for an object in a wall.


1 - Full Break with Caps
2 - Full Break no Caps
3 - Half Break
4 - No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
breakMode :INTEGER) : Boolean;
def vs.SetObjWallBreakMode(objH, wallH, breakMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful setting of the break mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017