VS:SetObjWallBreakMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(wikify to remove extra spaces)
m (wikify)
(2 intermediate revisions by the same user not shown)
Line 7: Line 7:
<desc>
<desc>
Set the break mode for an object in a wall.
Set the break mode for an object in a wall.
# Full Break with Caps
1 - Full Break with Caps<BR>
# Full Break no Caps
2 - Full Break no Caps<BR>
# Half Break
3 - Half Break<BR>
# No Break
4 - No Break<BR>


The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
Line 53: Line 53:
* objH is null
* objH is null
* wallH is null
* wallH is null
objH is not contained in wallH.</return>
* objH is not contained in wallH.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2020.04.14)
Fails on Round Walls, while on straight walls you must regen the wall and coerce a redraw (bug filed, tested on VW 2019, 2020).
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 12:33, 14 April 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the break mode for an object in a wall.

1 - Full Break with Caps
2 - Full Break no Caps
3 - Half Break
4 - No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
breakMode :INTEGER) : Boolean;
def vs.SetObjWallBreakMode(objH, wallH, breakMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful setting of the break mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null
  • objH is not contained in wallH.

Remarks

(Orso, 2020.04.14)

Fails on Round Walls, while on straight walls you must regen the wall and coerce a redraw (bug filed, tested on VW 2019, 2020).

Version

Availability: from Vectorworks 2017