VS:SetObjPropVS

From Vectorworks Developer
Revision as of 21:48, 28 April 2020 by Ptr (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events. This page doesn't exist anymore :-(

FUNCTION SetObjPropVS(
PropertyID :LONGINT;
PropertyVal :BOOLEAN) :BOOLEAN;
def vs.SetObjPropVS(PropertyID, PropertyVal):
    return BOOLEAN

Parameters

PropertyID LONGINT
PropertyVal BOOLEAN

Remarks

[Ptr 04/28/2020]

_bResult = vs.SetObjPropVS(2, True)  # kObjXPropHasLayerScaleDeps
_bResult = vs.SetObjPropVS(8, True)  # kObjXPropHasUIOverride
_bResult = vs.SetObjPropVS(18, True)  # kObjProp_AcceptStates
_bResult = vs.SetObjPropVS(49, True)  # kObjXSupportsStyles
_bResult = vs.SetObjPropVS(50, True)  # kObjXPropSupportGenericStoryLevel
_bResult = vs.SetObjPropVS(53, True)  # kObjXPropSupportResourcePopup

Version

Availability: from All Versions

This is drop-in function.