VS:SetObjPropVS

From Vectorworks Developer
Revision as of 07:51, 24 September 2019 by Ptr (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events.

FUNCTION SetObjPropVS(
PropertyID :LONGINT;
PropertyVal :BOOLEAN) :BOOLEAN;
def vs.SetObjPropVS(PropertyID, PropertyVal):
    return BOOLEAN

Parameters

PropertyID LONGINT
PropertyVal BOOLEAN

Remarks

[Ptr 09/23/2019]

CONST
  {ObjPropVS}
  kObjProp_HasLayerScaleDeps = 2; {PropertyID}
  kObjProp_HasUIOverride = 8; {PropertyID}
  kObjProp_AcceptStates = 18; {PropertyID}
# ObjPropVS
kObjProp_HasLayerScaleDeps = 2  # PropertyID
kObjProp_HasUIOverride = 8  # PropertyID
kObjProp_AcceptStates = 18  # PropertyID

Version

Availability: from All Versions

This is drop-in function.