VS:SetObjPropVS: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(fix old link to vectorlab)
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events. This page doesn't exist anymore :-(
See [[VS:Object Events]].  
</desc>
</desc>



Latest revision as of 17:54, 13 May 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See VS:Object Events.

FUNCTION SetObjPropVS(
PropertyID :LONGINT;
PropertyVal :BOOLEAN) :BOOLEAN;
def vs.SetObjPropVS(PropertyID, PropertyVal):
    return BOOLEAN

Parameters

PropertyID LONGINT
PropertyVal BOOLEAN

Remarks

[Ptr 04/28/2020]

_bResult = vs.SetObjPropVS(2, True)  # kObjXPropHasLayerScaleDeps
_bResult = vs.SetObjPropVS(8, True)  # kObjXPropHasUIOverride
_bResult = vs.SetObjPropVS(18, True)  # kObjProp_AcceptStates
_bResult = vs.SetObjPropVS(49, True)  # kObjXSupportsStyles
_bResult = vs.SetObjPropVS(50, True)  # kObjXPropSupportGenericStoryLevel
_bResult = vs.SetObjPropVS(53, True)  # kObjXPropSupportResourcePopup

Version

Availability: from All Versions

This is drop-in function.